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IndexRef plugin for FrameMaker
Purpose
A standard index in a document can contain two types of entry. The first type of entry refers to a 
location in the body of the document, and generally contains a page number. For example,

rocks 52

The second type of entry, called a cross reference entry, helps the reader navigate internally within the 
index. Cross reference entries are usually identified by the terms see and see also, and do not contain 
page numbers. For example, 

stones. See rocks

Problems with cross reference entries
In FrameMaker, the <$nopage> building block creates cross reference entries. It suppresses the 
page number from an entry in a generated index, but does not alter the entry in any other significant 
way. For print purposes, this works well, but it creates problems when used with online documents.

If a cross reference entry in an index file is created using the <$nopage> building block, the 
hyperlink for the entry links to the wrong place. 

Users expect the hyperlink to link to another location in the index. FrameMaker, however, creates a 
hyperlink that links to the location in the source document where the cross reference entry was 
defined.

For example, in a PDF with this as an index entry
stones. See rocks

clicking the entry jumps to the body of the document where the index marker was defined. It does 
not jump to the rocks entry in the index.

Fixing cross reference entries with IndexRef
IndexRef fixes cross reference entries by rewriting them to link to the expected target. Instead of 
linking to the location of the index marker in the source document, the entries link to the target of 
the cross reference in the index. 

An additional benefit of IndexRef is that it performs some quality checks on the index. Any cross 
references that do not have a corresponding target entry will be flagged as potential errors.

Note that IndexRef modifies the entries in the generated index, but it does not change the source 
documents in any way. If for some reason IndexRef produces undesirable results, you can always 
disable IndexRef and regenerate the index.

IndexRef is compatible with other FrameMaker indexing tools like IxGen and Index Tools 
Professional.

System requirements
IndexRef for Windows requires FrameMaker 7.0 or higher for Windows.

New in version 1.4
There is no longer any need to obtain a license key. The evaluation version if IndexRef is fully 
functional, with an occasional reminder to license the product.
Sundorne Communications www.sundorne.com



IndexRef 2
New in version 1.3
Version 1.3 contains the following improvements:

• Improved search algorithm resulting in much faster performance and better matching of target 
entries.

• Hyperlinked error file that jumps directly to the incorrect cross references.

New in version 1.2
Version 1.2 contains the following improvements:

• Support for FrameMaker installations in languages other than English. In French, for example, 
the paragraphs in an index are named Niveau1IX instead of Level1IX.

• Support for other types of index files, like subject indexes, where the paragraph suffix is SIX 
instead of IX.

• Bug fix: Previous versions crashed when the LinkCharTag character format was not defined in 
the index file.

• Bug fix: Version 1.2 ensures that the character formatting of the index marker matches the char-
acter formatting of the start of the cross reference text. This makes the hyperlink area as large as 
possible.

New in version 1.1
Version 1.1 contains the following improvements:

• Support for “stacked” entries, where See also in one entry is followed by a list of cross references 
in the paragraphs that follow

• The ability to tag all cross references with a particular character tag
• The ability to set different configuration options for different index files, without having to edit 

the IndexRef.ini file.

Installation
IndexRef is supplied in a single file, IndexRef.zip, containing three files. The files are:

• IndexRef.dll — the plugin
• IndexRef.ini — a configuration file needed by the plugin
• IndexRef.pdf — the documentation

To install IndexRef, create a new sub-directory below the fminit\Plugins directory in your 
FrameMaker installation directory. The name of the directory is not important, but it is simplest to 
name it after the plugin. For example, if the FrameMaker product is installed in 

C:\Program Files\Adobe\FrameMaker7.0

then create a new directory named IndexRef in
C:\Program Files\Adobe\FrameMaker7.0\fminit\Plugins

Using WinZip or another similar program, unzip IndexRef.zip into the new directory. Edit 
IndexRef.ini as required. The next time FrameMaker is started, it will search the Plugins directories 
and load IndexRef automatically.

Licensing
To pay for your copy of IndexRef, visit www.sundorne.com. The evaluation version is fully 
functional.
Sundorne Communications www.sundorne.com
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Upgrading
To upgrade IndexRef from a previous version, replace IndexRef.dll and restart FrameMaker. 
Existing licences will continue to work.

Removing IndexRef
To remove IndexRef, simply remove the files from the Plugins directory. IndexRef does not make 
any other modifications to your computer.

Operation
IndexRef can be run on demand or automatically. 

IndexRef adds entries to two standard FrameMaker menus. On the Edit menu, it adds an entry 
labelled Resolve Index XRefs. This option is used to run IndexRef on a single index file.

On the Edit menu that is active when a book is selected, it adds an entry labelled Auto-resolve Index 
XRefs. This option toggles automatic execution of IndexRef. If the option is selected, then index 
files will be processed by IndexRef whenever they are generated by an Update Book command.

Running IndexRef for a single index file
To run IndexRef on demand, open an index file. Make it the active document. Select Edit>Resolve 
Index XRefs. This will run IndexRef for the currently active file. If the file is not a generated index, 
you will get an error message

This command can only be run on a generated standard index file.

Running IndexRef automatically for a book
To run IndexRef automatically whenever you generate an index file for a book, open the book file 
and make it the active document. Select Edit>Auto-resolve Index XRefs. When this option is 
selected, IndexRef will run automatically whenever a standard index file is generated or regenerated 
for the book. 

Note that if the index file is not in the Generate column of the Update Book dialog, the index will 
not be generated and IndexRef will not run for the file.

What IndexRef does
IndexRef searches through the index file for paragraphs matching both these criteria:

• The entry does not contain a page number, indicating it was created with the <$nopage> build-
ing block.

• The entry does contain one of the cross reference strings. By default, these strings are See also 
and See, but they can be changed using configuration options. Note that the search is not case-
sensitive, so see also and see will match as well.

When IndexRef finds a paragraph matching the criteria, it searches the index file for a target 
location. If the target location exists, then IndexRef creates a hyperlink from the cross reference 
paragraph to the target paragraph. 

For example, if the index file contains an entry like this:
stones. See rocks

IndexRef will search the index file for a level 1 entry starting with “rocks”. If it finds the target 
entry, then IndexRef rewrites the hyperlink from the cross reference entry to point to the target 
entry. If the target entry is not in the index file, IndexRef generates an error.
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Multiple target entries
Some cross reference entries can contain multiple target entries. For example, the following entry

rock
See also sedimentary rock; igneous rock; metamorphic rock

points to three separate target entries. IndexRef will create three hyperlinks in the paragraph, to 
point to the three target entries. By default, the character separating different cross references is 
“;”, but it can be changed by configuring IndexRef.

Stacked entries
Some indexers prefer to stack multiple entries instead of listing them inside one entry. For example

rock
See also

igneous rock
metamorphic rock
sedimentary rock

IndexRef identifies stacked cross references by finding paragraphs that exactly match one of the 
cross reference strings. When it finds them, it searches the paragraphs immediately following for the 
cross reference text. As long as the following paragraphs are at a higher level they are assumed to 
contain cross reference text. So, if See also is at level 2, then any of the level 3 entries immediately 
below it in the index are assumed to contain cross reference text.

Index levels
Some cross reference entries can point to target entries that are not at the first level. For example, 
the following entry

lava. See rock, molten

points to a second-level entry molten of the first-level entry rock, like this
rock

molten 52

IndexRef will create an entry that links to the second-level entry. By default, the character 
separating different levels is “,”, but it can be changed by configuring IndexRef.

Assigning a new character format
The LinkCharTag configuration option can be used to tag all of the cross references with a new 
character tag. For example, you could define a character tag that makes hyperlinks blue and 
underlined, like this:

rock
See also sedimentary rock; igneous rock; metamorphic rock

Define the character tag in the character catalog for the index, then configure IndexRef to apply the 
tag to the cross references.

Using IndexRef with other languages
By default, IndexRef expects paragraphs to be named according to the conventions of English 
language installations of FrameMaker. In a standard index, the paragraphs will be named Level1IX, 
Level2IX, Level3IX, etc.

Other languages use different conventions. French language installations, for example, would use 
Niveau1IX, Niveau2IX, Niveau3IX, etc. 

To configure IndexRef to use these conventions, set the PgfPrefix configuration option.
Sundorne Communications www.sundorne.com



IndexRef 5
Using IndexRef with other types of generated indexes
By default, IndexRef is set up to run on standard indexes, which use a paragraph suffix of IX. 
Different types of generated indexes use a different suffix. Subject indexes, for example, use a 
suffix of SIX.

To configure IndexRef to run on a different type of generated file, use the PgfSuffix option. This 
can be done on a file-by-file basis.

Errors
If IndexRef cannot find a target entry, it writes details to the FrameMaker book error log. When it 
finds an error, it does not overwrite the original hyperlink, so you can find the source for the index 
entry and correct it.

Indexes and online help systems
Please note that you should take special care if you are converting your FrameMaker indexes to an 
online help format using a conversion tool like WebWorks Publisher or Mif2Go.

Many online help systems do not allow internal cross references in an index file. You may get 
unpredictable results if you process an index using IndexRef then convert the index as part of an 
online help system. This is a limitation of the online help format, and is not a problem with the 
operation of IndexRef or the conversion tool.

To help deal with this problem, use the NewPgfPrefix configuration option. With this option, all 
paragraphs containing cross reference entries are given a new paragraph format. For example, a 
Level2IX format would be changed to xLevel2IX. Then change the conversion template so 
xLevel2IX paragraphs output just the text of the entry and not the hyperlink. For details on this 
step, you will need to refer to the documentation for your conversion tool.

Configuration
Configuration for IndexRef can be done in two places. Configuration values for your entire session 
can be set in the IndexRef.ini file. To override the configuration values for a particular index file, 
you can create a reference page to hold the values.

The configuration parameters are:

Parameter Description

Licence Required. The licence key to use for this copy of IndexRef. This can be either a 
time-limited evaluation licence or a full licence. To obtain a licence, visit

www.sundorne.com.
This parameter must appear in the IndexRef.ini file. It has no effect if it also 
appears on the reference page.

RunOnGenerate Determines the initial setting of Auto-resolve Index XRefs on the book Edit 
menu. If

RunOnGenerate=1
then the option will be selected.

This parameter is only valid in the IndexRef.ini file. It has no effect if it also 
appears on the reference page.

NewPgfPrefix Used to assign a new paragraph format to every paragraph containing a cross 
reference. This can be used to identify the paragraphs for later conversion with a 
program like Mif2Go or WebWorks Publisher. For example, if 

NewPgfPrefix=x
then Level2IX paragraphs containing cross references will be converted to 
xLevel2IX paragraphs instead.
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Changing IndexRef.ini
To change any of the configuration parameters, edit the appropriate lines in IndexRef.ini using a 
text editor like Notepad. Do not use FrameMaker or any word processing program. Save the changes 
and restart FrameMaker.

This file must exist in the same directory as IndexRef.dll.

Any parameters set in IndexRef.ini will be default values for your FrameMaker session. Most of the 
parameters can be overridden for an individual file by defining a reference page in the particular file.

IndexRef reference page
There may be instances where you need to change the configuration parameters for an individual 
file. For example, one index file may be created using a different style than your standard. This 
might require different values for parameters like EntryDelimiter and LevelDelimiter.

LinkCharTag Character tag to apply to the cross reference entries. For example,
LinkCharTag=hyperlink

will tag all of the cross references with the <hyperlink> tag.

LevelDelimiter The delimiter used to separate levels in a cross reference entry. The default is
LevelDelimiter=,

EntryDelimiter The delimiter used to separate target entries in a cross reference entry. The 
default is

EntryDelimiter=;

IgnoreTrailing A list of characters to ignore if they occur at the end of a cross reference entry. 
The default is

IgnoreTrailing=.
so cross reference entries like

rocks. See stones.
will be handled properly.

PgfPrefix The paragraph prefix used in the generated index. The default is
PgfPrefix=Index

If you are using a version of FrameMaker for a language other than English, you 
may need to change this value. French language versions, for example, would 
require

PgfPrefix=Niveau

PgfSuffix The paragraph suffix used in the generated file. The default is
PgfSuffix=IX

If you are running IndexRef on a different type of generated index, you may 
need to change the suffix. Subject indexes, for example, would require 

PgfSuffix=SIX
This option is most commonly set in a reference page for a single file, instead of 
for the entire session.

XRefStringsDelimiter The delimiter used to separate entries in the XRefStrings parameter. This should 
appear in the configuration file before the XRefStrings parameter. The default is

XRefStringsDelimiter=,

XRefStrings A list of strings, separated by the delimiter defined in XRefStringDelimiter. Any 
of the strings in the list can be used to identify a cross reference entry. Longer 
entries should be listed first. For example, 

XRefStrings=See Also, See

Parameter Description
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Instead of changing IndexRef.ini for these special cases, do the following:

• Create a reference page in the index file. Name the reference page
IndexRef

• Draw a text frame anywhere on the reference page.
• Enter the IndexRef parameters in the text frame, one parameter per paragraph. Use the same 

format as you would use in IndexRef.ini.

The next time you run IndexRef on this file it will use the parameters on the reference page.

Troubleshooting
If a target entry cannot be found, IndexRef writes a message to the FrameMaker book error log. The 
message will be similar to this:

The target for the cross reference "rocks" 
in the entry "stones. See rocks" could not be found.

Click the hyperlink to jump to the cross reference entry. Determine what the entry should say. Hold 
the Control and Alt keys down and click the entry to open the source document containing the 
index marker. Edit the marker and regenerate the index.

Verifying IndexRef’s operation
To test that IndexRef works properly, first generate an index file with the Auto-resolve Index XRefs 
option turned off. Open the index file and turn on text symbols (View>Text Symbols). Find a cross 
reference entry. It should look something like this

rock
7See also sedimentary rock; igneous rock; metamorphic rock¶

with the hyperlink marker at the beginning of the paragraph. Run IndexRef on the index file. There 
should be a new marker at the beginning of each target string

rock
See also 7sedimentary rock; 7igneous rock; 7metamorphic rock¶

Hold the Control and Alt keys down, and click on one of the target strings. The insertion point 
should move to the beginning of the target entry.

Create a PDF from the book and perform the same test on the cross reference entries in the index.

Limitations
There can be a maximum of 10 different cross reference strings in the XRefStrings list.

IndexRef is supplied “as is”. There is no warranty, either express or implied, that IndexRef will 
function as described here. Sundorne Communications cannot be held responsible for the use of 
IndexRef. We encourage you to try the evaluation licence before purchasing IndexRef, to ensure 
that it will meet your needs.

Questions and Comments
Please share your experiences with us. If you try IndexRef and it doesn’t work as expected, let us 
know. Visit www.sundorne.com for contact information.
Sundorne Communications www.sundorne.com
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